Smile Identity
Search…
⌃K

IOS

Integration Options

The IOS SDK is available on cocoapods as Smile_Identity_SDK
Note: The iOS SDK only runs on 64-bit devices. If you build your app with 32-bit support, check the device's architecture before using this API. this affects most simulators but not devices in current usage

Smile ID UI

This is a quick integration option which has prebuilt screens for Selfie and ID Document capture, This is recommended if you don't have too much customisation requirement for the Selfie and Document capture screens as this is something built to cut down on time to integration and also using our internal recommended integration methods

Smile ID Native SDK

This is the IOS SDK with all the building blocks on which Smile ID UI builds on and has all the components required to integrate on IOS. This is recommended if you have specific integration requirements particularly on the UI side where you would need a lot of flexibility compared to what Smile ID UI would allow.
Supported iOS versions are 10.0 to 15.2
  • Current XCode version : 13.x.x
  • Minimum supported IOS version is 10
  • Maximum supported IOS version is 15.2
To install the Smile Identity iOS library continue on to Adding the library.
Last modified 6mo ago